Impossible to work with ALT and CTRL modifiers with Wacom remote control

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
User avatar
skomdra
Posts: 128
Joined: 14 Aug 2010, 14:32

Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by skomdra » 09 Jul 2020, 23:34

Hi,
I want to use TVP with the wacom remote which comes with 24 inch models, however, I can't make it to respond on pressed alt or ctrl, so the whole set of workflows by using the alt key for the navigation goes to toilet. Interesting though, the other apps such as zbrush recognize alt without a problem. What seems to be a problem with TV paint and not recognizing when I press alt on my remote? How do I fix this? Is it a bug?
Thnx
-----
TV Paint 11.0.8-64 bits ; iMac (Retina 5K, 27-inch, Late 2014) ; OSX 10.14; AMD Radeon R9 M295X 4096 MB; Wacom Driver version: 6.3.31-5

User avatar
skomdra
Posts: 128
Joined: 14 Aug 2010, 14:32

Re: Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by skomdra » 09 Jul 2020, 23:45

I made it work once after the restart, but it behaves like the ALT button got stuck. Then I switched the remote on and off and now it doesn't work. Funny thing though is that the shift modifier works so it draws straight lines when I press that shift button on the remote. But Alt, no. Nothing. Fix it. Please. Thnx.
-----
TV Paint 11.0.8-64 bits ; iMac (Retina 5K, 27-inch, Late 2014) ; OSX 10.14; AMD Radeon R9 M295X 4096 MB; Wacom Driver version: 6.3.31-5

User avatar
skomdra
Posts: 128
Joined: 14 Aug 2010, 14:32

Re: Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by skomdra » 10 Jul 2020, 00:02

I restarted it again. This is for you to try to reconstruct the bug. It works when I try to use it on default settings, where the second bottom button on the middle of the remote is assigned to ALT modifier. It works as expected. But then, when I press the ctrl modifier together with alt it starts to rotate the canvas, and that is all expected. But from that moment on, it behaves like the alt key has stuck. The unstuck happens when I press the alt key on my keyboard. But after that the remote will not respond on pressing ALT any more, even after I tried to restart the program couple of times. Just to be absolutely sure that I am not missing something, I rebooted again and tried the problematic ALT CTRL combination and from then on there is nothing to do to force it to work other than reboot. And I am not going to reboot my machine every time I have to press alt and navigate my scene, if you know what I mean. Please report if you have the same behaviour and let's fix this. This is no way to work. If you think there is a problem with Wacom drivers, then help me how to fix it, please, we can have a remote session. I can't work like this.
btw, the touch ring also doesn't work, even though i assigned keyboard shortcuts for the zoom in and zoom out and assigned it to ring, no response. It is valid argument that this is about Wacom, but it is TVPaint I am having trouble with, not with any other Software.
Thank you.
-----
TV Paint 11.0.8-64 bits ; iMac (Retina 5K, 27-inch, Late 2014) ; OSX 10.14; AMD Radeon R9 M295X 4096 MB; Wacom Driver version: 6.3.31-5

User avatar
Dean
Site Admin
Posts: 285
Joined: 28 May 2018, 09:07

Re: Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by Dean » 10 Jul 2020, 09:37

Hello Skomdra,
I'm currently charging my Wacom remote, will conduct some tests in the afternoon.
-Sales and Support-
Probably a vampire

User avatar
skomdra
Posts: 128
Joined: 14 Aug 2010, 14:32

Re: Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by skomdra » 10 Jul 2020, 14:59

Dean wrote:
10 Jul 2020, 09:37
Hello Skomdra,
I'm currently charging my Wacom remote, will conduct some tests in the afternoon.
Thank you Dean. I also wrote to the wacom support, I will let you know if anything can be done.
cheers
-----
TV Paint 11.0.8-64 bits ; iMac (Retina 5K, 27-inch, Late 2014) ; OSX 10.14; AMD Radeon R9 M295X 4096 MB; Wacom Driver version: 6.3.31-5

User avatar
Dean
Site Admin
Posts: 285
Joined: 28 May 2018, 09:07

Re: Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by Dean » 10 Jul 2020, 16:02

Hello again,
It seems that our remote's dongle has died, I contacted Wacom to get a replacement ASAP, will keep you informed.
-Sales and Support-
Probably a vampire

User avatar
skomdra
Posts: 128
Joined: 14 Aug 2010, 14:32

Re: Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by skomdra » 10 Jul 2020, 17:19

thank you. I still didn't get back from the Wacom. Funny thing is, that I didn't find much report on this problem other than on adobe 4 year old forum where they mention to go back on the older Wacom driver and they call it sticky keys bug. But in the last 12 months nobody is mentioning this problem anywhere. I believe in this price range things should work as smooth as possible and this kind of problems should be solved swiftly. As they like my euros when I buy their products, I like my purchased products to deliver the promised property without bugs.
cheers
-----
TV Paint 11.0.8-64 bits ; iMac (Retina 5K, 27-inch, Late 2014) ; OSX 10.14; AMD Radeon R9 M295X 4096 MB; Wacom Driver version: 6.3.31-5

User avatar
Dean
Site Admin
Posts: 285
Joined: 28 May 2018, 09:07

Re: Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by Dean » 20 Jul 2020, 10:10

Hi Skomdra,
It is impossible to order the dongle for the remote alone now, even from Wacom's tech support.
Fortunately I have found somes cable to use it in wired mode, will conduct some tests today and tomorrow.
-Sales and Support-
Probably a vampire

User avatar
Dean
Site Admin
Posts: 285
Joined: 28 May 2018, 09:07

Re: Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by Dean » 22 Jul 2020, 16:07

Hello again,
It seems that our Express Key remorte is cursed. I can't get our Intuos or Cintiqs to detect it for some reason.
However, I check assigning CTRL and ALT to the Express Keys of multiple different Wacom tablets and they worked every time.

I will keep trying to get the remote to work.
-Sales and Support-
Probably a vampire

User avatar
cgmodeler
Posts: 86
Joined: 23 Oct 2012, 23:59
Location: Mexico/France/Japan
Contact:

Re: Impossible to work with ALT and CTRL modifiers with Wacom remote control

Post by cgmodeler » 23 Jul 2020, 07:55

Tested here with TVP 11.0.8 and the remote works fine, no sticking on CTRL or ALT

Have you checked on the diagnose tool that the key is released? Should be left button 11 and 14
wacomctrl1.JPG
wacomctrl1.JPG (61.38 KiB) Viewed 2375 times
www.cocoalopez.com
vimeo / 156794487
Desktop: TVP Pro 11.0.8 - 64bit Win 7 x64 48GB RAM - GTX1070 - Cintiq 27QHD Driver 6.3.29

Post Reply