El Capitan

Please use this part to report bugs & errors, ask questions & "How to..."
Robobob
Posts: 25
Joined: 04 Apr 2013, 17:50
Location: Netherlands
Contact:

El Capitan

Post by Robobob » 02 Oct 2015, 14:03

I was wondering if there's anyone who's tested Tvpaints behaviour yet on the new El Capitan OS for mac. I'm using Tvpaint 10.5.7 on a Macmini running Mavericks and i've been waiting to upgrade. I read there's been a lot of problems with Yosemite and I can't afford to loose time at the moment so thought better check!
Thanks!

User avatar
Thierry
Site Admin
Posts: 2203
Joined: 07 Jan 2013, 08:28

Re: El Capitan

Post by Thierry » 02 Oct 2015, 14:14

Robobob wrote:I was wondering if there's anyone who's tested Tvpaints behaviour yet on the new El Capitan OS for mac. I'm using Tvpaint 10.5.7 on a Macmini running Mavericks and i've been waiting to upgrade. I read there's been a lot of problems with Yosemite and I can't afford to loose time at the moment so thought better check!
Thanks!
To be honest, you should stay on Mavericks for now, until we will run some proper tests with El Capitan next week.
Si votre question a trouvé réponse, marquez votre sujet comme Résolu. ~ If your question has been answered, mark your topic as Solved.
------------------------------

User avatar
ematecki
Site Admin
Posts: 1999
Joined: 15 Feb 2006, 14:32

Re: El Capitan

Post by ematecki » 02 Oct 2015, 14:21

Robobob wrote:I can't afford to loose time at the moment
Then don't even think about upgrading....
https://discussions.apple.com/thread/72 ... 5&tstart=0" onclick="window.open(this.href);return false;
http://www.gottabemobile.com/2015/09/30 ... d-to-know/" onclick="window.open(this.href);return false;
You can choose your friends,
but you can't choose your family.

Robobob
Posts: 25
Joined: 04 Apr 2013, 17:50
Location: Netherlands
Contact:

Re: El Capitan

Post by Robobob » 02 Oct 2015, 14:27

Ok very clear thanks! Ill hold out on upgrading until i read the results of your tests.

User avatar
furushil
Posts: 404
Joined: 12 Feb 2012, 21:02
Location: Berlin
Contact:

Re: El Capitan

Post by furushil » 13 Oct 2015, 11:40

Thierry wrote:To be honest, you should stay on Mavericks for now, until we will run some proper tests with El Capitan next week.
Thierry, did you encounter any problems so far?
MAC OS 10.11.6 - TVpaint 11.0.8 PRO 64bit, Wacom Intuos Pro

User avatar
Thierry
Site Admin
Posts: 2203
Joined: 07 Jan 2013, 08:28

Re: El Capitan

Post by Thierry » 13 Oct 2015, 12:17

No, I haven't discovered anything problematic (yet).

However I have some updates regarding this bug (loss of quality when not drawing in fullscreen mode) that I am going to share on the dedicated topic :)
Si votre question a trouvé réponse, marquez votre sujet comme Résolu. ~ If your question has been answered, mark your topic as Solved.
------------------------------

User avatar
furushil
Posts: 404
Joined: 12 Feb 2012, 21:02
Location: Berlin
Contact:

Re: El Capitan

Post by furushil » 13 Oct 2015, 12:46

Ok thank you, I'm going to update then.
MAC OS 10.11.6 - TVpaint 11.0.8 PRO 64bit, Wacom Intuos Pro

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: El Capitan

Post by Elodie » 13 Oct 2015, 13:18

Little note : since I upgraded El Capitan, my Mac Book Pro is noisy like a vacuum cleaner. That's quite annoying...

User avatar
furushil
Posts: 404
Joined: 12 Feb 2012, 21:02
Location: Berlin
Contact:

Re: El Capitan

Post by furushil » 13 Oct 2015, 16:03

I updated to OSX 10.11 now.
The first thing I noticed is that every time I quit TVPaint, it crashes and OSX gives me a crash report.
This is bad because I cannot save any new brushes. The crash prevents TVPaint from saving the brushes at the end.
Other than that it seems to work fine so far.

Edit: When I am in fullscreen mode and quit TVPaint, it crashes but when I am not in fullscreen mode it quits normally without crashing.

I also downloaded the newest Wacom drivers. The tablet also works fine but I think the brush lag is a little bit worse than before. I experienced this in every OSX version so it is probably not related to 10.11 El Capitan.
Since I already got used to it, it is not a big deal for me but if anybody knows how to fix it please let me know (see video below).

In this video line smoothing is not activated:
https://www.dropbox.com/s/9cbnz5m4xf2ed ... 0.mov?dl=0" onclick="window.open(this.href);return false;
MAC OS 10.11.6 - TVpaint 11.0.8 PRO 64bit, Wacom Intuos Pro

User avatar
Fabrice
Posts: 10079
Joined: 17 Jul 2007, 15:00
Contact:

Re: El Capitan

Post by Fabrice » 13 Oct 2015, 16:35

I also downloaded the newest Wacom drivers. The tablet also works fine but I think the brush lag is a little bit worse than before. I experienced this in every OSX version so it is probably not related to 10.11 El Capitan.
Since I already got used to it, it is not a big deal for me but if anybody knows how to fix it please let me know (see video below).
have you checked this topic : http://forum.tvpaint.com/viewtopic.php? ... 223#p86886" onclick="window.open(this.href);return false; ?
Fabrice Debarge

User avatar
furushil
Posts: 404
Joined: 12 Feb 2012, 21:02
Location: Berlin
Contact:

Re: El Capitan

Post by furushil » 13 Oct 2015, 18:24

Fabrice wrote:have you checked this topic : viewtopic.php?f=10&t=9223#p86886 ?
I made another test and now I think my problem is not Wacom related at all. When I draw long lines fast, the line cannot quite catch up with the cursor while drawing.
But as I said it was always like that. It does not happen in Photoshop though. I don't have any other program to test it.

There is actually a noticeable difference between TVPaint 11.0.2 Pro 32bit and TVPaint 11.0.2 Pro 64bit. In the 32 bit version the stroke catches up with the cursor but in the 64 bit version it doesn't.

I have created a new topic for this issue here: viewtopic.php?f=10&t=9427" onclick="window.open(this.href);return false;
MAC OS 10.11.6 - TVpaint 11.0.8 PRO 64bit, Wacom Intuos Pro

ten_zero
Posts: 805
Joined: 03 Sep 2009, 07:28
Location: The bottom of English divide

Re: El Capitan

Post by ten_zero » 14 Oct 2015, 01:56

"Back to OS 10.9.5 Marvericks", the answer for a while.

"El Capitan" has too much trouble and vain edition :
  • Flat but not distinct & contrast UI design ( look at grayscale mode )
  • "Shake mouse to find mouse pointer" preset function become conflict with Wacom "not perfect yet" tablet driver
  • Deny for support Microsoft hardware ( or other peripheral equipment )
    - for 149,00 € / £109.00 / ¥14,800 / $129.00 "aluminium slate" genuine products
  • Incomprehensible change for some Kanji language's system font ( means "character code & font-face culture's gap" )
  • CPU burner ( poor my Mac mini ! )
  • the worst kana-kanji Imput method with "wrong prodict auto convert" function
    - imagine "completely wrong" forced auto correct / diacritical mark / spell checker" for your Latin alphabet language
  • "Photos" - the end of "Aperture"
  • Crushed on my native language's DTP "vertical writing" software and character code - welcome to garbling world
  • Final edition for working with Adobe CS4 - CS6 products - the end of Apple JAVA VM maintenance support
  • More carefuly selected movie export format by Apple farm ; none live without QuickTime 7 Pro license

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: El Capitan

Post by Elodie » 14 Oct 2015, 09:21

This is a shame from Apple regarding the wya they manage kanjis !

I also noticed few weird behaviours on Capitan (my mouse was gone when I started my Mac this morning and when I make right clicks, the contextual menu has weird glitches when I move the cursor... :| )

Furshil : I don't have such crashes ! I assume your config crashes once and now, each time you close TVPaint, it continues to crash.

User avatar
furushil
Posts: 404
Joined: 12 Feb 2012, 21:02
Location: Berlin
Contact:

Re: El Capitan

Post by furushil » 14 Oct 2015, 10:48

Elodie wrote:Furshil : I don't have such crashes ! I assume your config crashes once and now, each time you close TVPaint, it continues to crash.
Is there a way to solve this? I created a new config but the crash still happens.
MAC OS 10.11.6 - TVpaint 11.0.8 PRO 64bit, Wacom Intuos Pro

User avatar
Fabrice
Posts: 10079
Joined: 17 Jul 2007, 15:00
Contact:

Re: El Capitan

Post by Fabrice » 14 Oct 2015, 12:37

any error report from Apple ?
Fabrice Debarge

Post Reply