navigating using the ALT key Topic is solved

Please use this part to report bugs & errors, ask questions & "How to..."
User avatar
Joost
Posts: 279
Joined: 24 Nov 2011, 13:16

navigating using the ALT key

Post by Joost » 29 Mar 2021, 10:08

Hi,

Another TVP 11.5.1 question:
I always navigate (zoom in/out and move my canvas) by clicking the ALT key and then (right)click my Wacom pen.

In tvpaint 10.5 this worked perfect, but since I'm using tvpaint 11.5.1 I noticed that it's less responsive. A lot of the times when clicking ALT to navigate, I'm still drawing a line and vice versa; after I have navigated successfully and want to draw again, it's still moving my canvas in stead of drawing a line.

Does anyone recognise this "problem"?

I'm using Mac OS Big Sur
TVPaint 11.5.1
Wacom Cintiq QHD
Mac OS 11.2.3, Mac mini 2020 Apple M1 chip, 16GB RAM, Wacom Cintiq 27 QHD (no touch), Wacom Driver 6.3.42-1.
TVP Pro 11.5.1

User avatar
Joost
Posts: 279
Joined: 24 Nov 2011, 13:16

Re: navigating using the ALT key

Post by Joost » 29 Mar 2021, 12:30

The longer I work with it, the more it bothers me.

I'm very close to downgrading back to TVP 10.5 again :D

Nobody else has this issue?
Mac OS 11.2.3, Mac mini 2020 Apple M1 chip, 16GB RAM, Wacom Cintiq 27 QHD (no touch), Wacom Driver 6.3.42-1.
TVP Pro 11.5.1

User avatar
GerhardHuman
Posts: 16
Joined: 12 Feb 2019, 08:23
Contact:

Re: navigating using the ALT key

Post by GerhardHuman » 29 Mar 2021, 12:36

Hi, yes I have the same issue here. Alt would stay active after I zoomed in/out or pan around. Then I would need to press it again to get back to drawing mode.
Other times it would just not activate and I would need to try again...

I first thought it was my keyboard but it does the same with the alt button on my Wacom key.

Mac OS 10.15.7
iMac Late 2013
3.2 GHz Quad Core intel i5
24GB memory
Nvidia GeForce GT 755M 1GB

TV Paint11.0.9 64bits
TV Paint 11.0.9 Std iMac 3.2GHz Wacom Cintiq 24 pro (no touch)

User avatar
Thierry
Site Admin
Posts: 2373
Joined: 07 Jan 2013, 08:28

Re: navigating using the ALT key

Post by Thierry » 29 Mar 2021, 12:39

Doesn't ring a bell to me.
We'll check on our Cintiq and see if it happens to us as well.
Si votre question a trouvé réponse, marquez votre sujet comme Résolu.
If your question has been answered, mark your topic as Solved.

User avatar
D.T. Nethery
Posts: 2983
Joined: 27 Sep 2006, 19:19

Re: navigating using the ALT key

Post by D.T. Nethery » 29 Mar 2021, 14:12

Joost wrote:
29 Mar 2021, 10:08
A lot of the times when clicking ALT to navigate, I'm still drawing a line and vice versa; after I have navigated successfully and want to draw again, it's still moving my canvas in stead of drawing a line.

Does anyone recognise this "problem"?
I cannot reproduce the problem here . ALT works as it should to move the canvas. As soon as I release ALT it returns to Drawing mode.

Animator, TVPaint Beta-Tester, Animation Educator and Consultant.
MAC OS 10.14.6 , Macbook Pro Retina 15-inch, Late 2013,
2.3 GHz Intel Core i7, 16 GB Memory , TVPaint PRO 11.5.1 - 64bit ,
Wacom Cintiq 21 UX ,Wacom Intuos Pro 5 , Wacom driver version 6.3.39-1

User avatar
Joost
Posts: 279
Joined: 24 Nov 2011, 13:16

Re: navigating using the ALT key

Post by Joost » 29 Mar 2021, 14:48

D.T. Nethery wrote:
29 Mar 2021, 14:12
I cannot reproduce the problem here . ALT works as it should to move the canvas. As soon as I release ALT it returns to Drawing mode.
Lucky you :)
Thanks for checking it out.
GerhardHuman wrote:
29 Mar 2021, 12:36
Hi, yes I have the same issue here. Alt would stay active after I zoomed in/out or pan around. Then I would need to press it again to get back to drawing mode.
Other times it would just not activate and I would need to try again...
Good to know that I'm not the only one. Hopefully a solution will be found soon....
Mac OS 11.2.3, Mac mini 2020 Apple M1 chip, 16GB RAM, Wacom Cintiq 27 QHD (no touch), Wacom Driver 6.3.42-1.
TVP Pro 11.5.1

User avatar
Matthieu
Site Admin
Posts: 12
Joined: 11 Jan 2021, 13:10

Re: navigating using the ALT key

Post by Matthieu » 29 Mar 2021, 14:52

I wasn't able to reproduce this "alt key lock"' issue.

Did you try to use another keyboard to see if the problem still occurs?

User avatar
Joost
Posts: 279
Joined: 24 Nov 2011, 13:16

Re: navigating using the ALT key

Post by Joost » 29 Mar 2021, 15:13

Matthieu wrote:
29 Mar 2021, 14:52
I wasn't able to reproduce this "alt key lock"' issue.

Did you try to use another keyboard to see if the problem still occurs?
Yes, I tried another keyboard. Same problem...
It first appeared when upgrading to TVP 11.5 (from TVP 10.5) last week. With TVP 10 I used the same keyboard: no problem.
Both alt-keys are affected.
Mac OS 11.2.3, Mac mini 2020 Apple M1 chip, 16GB RAM, Wacom Cintiq 27 QHD (no touch), Wacom Driver 6.3.42-1.
TVP Pro 11.5.1

User avatar
GerhardHuman
Posts: 16
Joined: 12 Feb 2019, 08:23
Contact:

Re: navigating using the ALT key

Post by GerhardHuman » 29 Mar 2021, 15:30

Thanks for looking into it.
Yes it's not something that happens ALL THE TIME, it's quite infrequent but it does happen regularly.
I would say every 1min or so while I'm actively drawing... you can imagine that it does get annoying.

It never happened before. It's something new, started noticing it around 2months back...

(Also ruled out the keyboard)
TV Paint 11.0.9 Std iMac 3.2GHz Wacom Cintiq 24 pro (no touch)

User avatar
Joost
Posts: 279
Joined: 24 Nov 2011, 13:16

Re: navigating using the ALT key

Post by Joost » 30 Mar 2021, 08:51

GerhardHuman wrote:
29 Mar 2021, 15:30
I would say every 1min or so while I'm actively drawing... you can imagine that it does get annoying.
Here it's a lot more that once every minute. It happens several times every minute.
It's almost impossible to work like this.

Can it be a Wacom problem?

I updated my profile signature with all my specs. Hopefully this helps...
Mac OS 11.2.3, Mac mini 2020 Apple M1 chip, 16GB RAM, Wacom Cintiq 27 QHD (no touch), Wacom Driver 6.3.42-1.
TVP Pro 11.5.1

User avatar
Joost
Posts: 279
Joined: 24 Nov 2011, 13:16

Re: navigating using the ALT key

Post by Joost » 30 Mar 2021, 12:43

The more I'm experiencing this issue, the more I think this could be a Wacom "problem". It feels like my Wacom still thinks I'm drawing, while my pen not touching the screen...
Could this be a possibility?

I recently installed the newest Wacom driver on my new computer. Should I maybe try to install an older version?
Mac OS 11.2.3, Mac mini 2020 Apple M1 chip, 16GB RAM, Wacom Cintiq 27 QHD (no touch), Wacom Driver 6.3.42-1.
TVP Pro 11.5.1

User avatar
Joost
Posts: 279
Joined: 24 Nov 2011, 13:16

Re: navigating using the ALT key

Post by Joost » 30 Mar 2021, 14:43

Ok, I might have found a very, very simple solution on Reddit:

change the Wacom pen nib :oops:


Maybe it's to soon to say that this is the solution, but in the last 10 minutes the problem has appeared less frequently...
Mac OS 11.2.3, Mac mini 2020 Apple M1 chip, 16GB RAM, Wacom Cintiq 27 QHD (no touch), Wacom Driver 6.3.42-1.
TVP Pro 11.5.1

User avatar
Matthieu
Site Admin
Posts: 12
Joined: 11 Jan 2021, 13:10

Re: navigating using the ALT key

Post by Matthieu » 30 Mar 2021, 15:03

I'm using the 6.3.42-1 Wacom drivers as well.
change the Wacom pen nib
It could indeed very well be the issue! Please let us know if it seems to have solved this problem.

User avatar
Joost
Posts: 279
Joined: 24 Nov 2011, 13:16

Re: navigating using the ALT key

Post by Joost » 30 Mar 2021, 15:22

Matthieu wrote:
30 Mar 2021, 15:03
I'm using the 6.3.42-1 Wacom drivers as well.
change the Wacom pen nib
It could indeed very well be the issue! Please let us know if it seems to have solved this problem.
It definitely helped, but unfortunately the problem still exits... less often, but it's still there...
Mac OS 11.2.3, Mac mini 2020 Apple M1 chip, 16GB RAM, Wacom Cintiq 27 QHD (no touch), Wacom Driver 6.3.42-1.
TVP Pro 11.5.1

User avatar
GerhardHuman
Posts: 16
Joined: 12 Feb 2019, 08:23
Contact:

Re: navigating using the ALT key

Post by GerhardHuman » 01 Apr 2021, 08:59

Changed the Wacom pen nib : Problem still persists :(
It's really hard to work like this. The biggest issue is that I'm drawing, then using alt to zoom in and out but because Alt doesn't register it's just reading the right-click on the pen to switch to eraser... then I erase parts of my drawing and have to keep hitting undo... this happens all the time so you can imagine how annoying it gets :(

It never used to happen. Still have the same Wacom tablet, so it can only be a Mac OS update that doesn't work well with TV Paint.
I also started experiencing hectic lagging a while back, also probably because of a Mac OS update, this is happening in Photoshop as well, so not TV Paint specific...
Sigh... they just keep updating the software that makes everything worse... expecting us to keep buying new hardware...
TV Paint 11.0.9 Std iMac 3.2GHz Wacom Cintiq 24 pro (no touch)

Post Reply