Page 1 of 1

"Save project as" Crash

Posted: 14 May 2020, 21:31
by Padruig
I have a rather concerning issue that I has occurred twice since upgrading to TVP Pro 11.0.10 The program will hang when I try to use the "Save project as" command. I type in the new file name and hit save on the file requester but it stops there, it does not save. The file requester greys out but does not disappear and I can do nothing to get rid of it.(TVPaint preferences are set to use the systems file requester) If left alone for a while the requester may appear normally again showing me my system files and what not. As soon as I hit save or cancel it just greys out again and I can do nothing. I have to force quit TVPaint and lose any work I had since the last save.

I restarted my computer, opened the file again and tried "Save project as" and it crashed again. I opened a different file, and it would save a copy properly.

As a test I opened the file that was causing the issue again and used the "Save project" command and it worked as expected. I then tried "Save project as" and that started to work again. So I have no idea what the problem is, but this is the second time that I have run into this particular problem.

I will have to remember to save the file before I save a version of the file if I do not want to lose work.

I am running TVP Pro 11.0.10 on macOS 10.15.4 (Catalina)
iMac, 3.4 GHz Quad-Core, 16GB memory, radeon pro 570

Re: "Save project as" Crash

Posted: 22 May 2020, 12:52
by Xavier
I wasn't able to reproduce the same behaviour on my installation (TVPaint 11.0.10 on Linux Deb 64).

Before anything, have you tried to remove your TVPaint preference files from your user directory ?

Re: "Save project as" Crash

Posted: 22 May 2020, 19:40
by Padruig
Thanks for looking into it. It hasn't happened since and everything else about the new version seems great, speed is fantastic. I don't know what I was doing the first time it happened, the second time it happened I am pretty sure I was copying multiple clips from one file to another and then tried saving a new version. Maybe that will help you try and recreate it.

I have not tried to remove my preference files. I will back everything up and try that over the weekend.

I'll let you know if I run into it again. Many thanks!

Re: "Save project as" Crash

Posted: 25 May 2020, 09:13
by Xavier
You're welcome :)