Page 4 of 5

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 25 Jul 2020, 04:47
by gjeaks
Hi, I opened TVP after a few months now (because of the lag issue encountered with the update of Catalina). A lot of issues which I encountered earlier were solved. Except for the brush lag. Right clicking the mouse seemingly recovers the brush for a bit before it goes back to lagging again. Any new brush selected introduces the lag again.

I temp moved to CSP because of this issue, but TVPaint is TVPaint ^_^

Does downgrading TVP help?

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 27 Jul 2020, 08:47
by Dean
Hello Gjeaks,
Are you using 11.0.9 or 11.0.10?

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 02 Aug 2020, 06:01
by gjeaks
Hi Dean, sorry for the delay.

I am using 11.0.10.

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 05 Aug 2020, 11:42
by schwarzgrau
There isn't an update for years, than 10.0.9 comes up, which biggest improvement is that the Standard version now works in 64 bits too, but introduces a really annoying lag. You fix this lag but introduce another one with 10.10. Than nothing happens for months. I have to say at the moment I really don't even consider TVPaint for my next project, since It feels like a slowly dying software (sorry if I'm a bit overdramatic here). It's still the best 2D animation software for me at the moment, but I already try out all possible alternatives, since I don't see any progress.

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 07 Aug 2020, 11:28
by Thierry
Hi schwarzgrau,

I understand the frustration about the lag, but as we've said before, the lag is random, not everybody has it, and we cannot reproduce it consistantly.
Some people have it with 11.0.9 and not with 11.0.10, others have it with 11.0.10 and not with 11.0.9, and some also don't have it at all (wether it's 11.0.9 & 11.0.10).
The only common point that we've found with all those that have the lag is that they're using Cintiqs.

We don't have a definitive solution about it, only small solutions. Some of the small solutions don't work on all people while they might work for others.

As for the updates, while it's true that there had been a very long delay between 11.0.8 and 11.0.9 (due to some people leaving the company and us hiring new people), since September 2019 we've released two updates (one of them during confinement), and version 11.5 will release during Fall.
We're also working on a major new version, but that takes time. We are still supporting v11 and we don't plan on ending its support anytime soon.

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 07 Aug 2020, 11:48
by schwarzgrau
Hi Thierry,
Thank you for your reply. The weird thing is that there is already a pretty consistent bug with Cintiqs, if you switch from another app back to TVPaint, where you can only draw if you use the back of the pen first (you probably already aware of). Seems like there is some major incompatibility with Cintiqs. I'm really sorry you can't reproduce one of these errors, since probably most animators use them.

I'm aware that some people left the company and I'm sure that affects a small company like TVPaint a lot, even if it was some years ago. The features added/bugs fixed in the last two updates seem at least to me pretty minor compared to everything which was added from 10.6 to 10.7 or 10.7 to 10.8, especially if you consider how long there wasn't an update. However that you working on 11.5 and maybe 12 explains it perfectly for me. That's something I was hoping for and I'm really happy to hear.
Thank you Thierry

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 10 Aug 2020, 13:07
by Xavier
The lag is an issue, that's for sure. The creator of TVPaint didn't expect his baby to be used in such big screen resolutions !
Because yes, the lag is caused by these huge resolutions. The higher is your screen resolution, the more computations TVPaint has to inflict to your processor.

So there's a traffic jam somewhere. But since the traffic is already full, it's not that easy to optimize.

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 10 Aug 2020, 13:36
by schwarzgrau
Ok this makes perfect sense. The core isn't the freshest, but the 10.0.8 still works flawlessly for me.

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 12 Aug 2020, 10:07
by daninski
I've been animating on @ 4K on my current project with no lag, BUT I'm using 11.0.8 still... So I guess the huge resolution problem appears and disappears between versions?

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 12 Aug 2020, 11:04
by Xavier
daninski wrote:
12 Aug 2020, 10:07
I've been animating on @ 4K on my current project with no lag, BUT I'm using 11.0.8 still... So I guess the huge resolution problem appears and disappears between versions?
Daninski, If I refer to your signature, your iMac resolution is 1 920 x 1 080 right ?
At this resolution you could even do 8K animation, it should be okay ^^

The issue is related with the amount of hardware pixels to manage, not the amount of pixels in your project.

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 12 Aug 2020, 14:32
by daninski
That's true, but I got terrible playback lag in 11.0.9 that made review of my animation impossible. I haven't tried the newer versions yet because I'm still mid-project. I will give them a go when everything is delivered. BTW, I'm saying this not as a critique of TVP or their people. I'm offering up my experience of the problem as more information is more useful. Me and TVPaint are BFF.

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 12 Aug 2020, 15:07
by Xavier
Sure, no worries :wink:

Still we're developers, not animation specialists (or just a little), so we're always interested in having some feedbacks from you guys.
The most difficult thing is to predict all situations, all configurations.

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 31 Aug 2020, 03:32
by Soom
I have upgraded to TVPaint 11.0.10 PRO 64bit version and I confirm, that on my Mac there are a lot of lags, which makes working impossible. Very strong lag while drawing, some navigating and interface lags, etc. It is the same as it was in 11.0.9 I think. But installing a 32 bit version solves the issue and I can work normally (although I did get a popup that the app in not optimized for this Mac, but I ignored it)...
My Mac specs are in the signature

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 31 Aug 2020, 10:40
by EmmaMurphy1964
In this case it's worth sticking to 11.0.8 since it's working the best. We'll see what improvements will come in the next version and maybe the lag issues will be fixed :)

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Posted: 31 Aug 2020, 23:06
by Soom
EmmaMurphy1964 wrote:
31 Aug 2020, 10:40
In this case it's worth sticking to 11.0.8 since it's working the best. We'll see what improvements will come in the next version and maybe the lag issues will be fixed :)
But actually I don't see a difference between 64 and 32 bit. So for me it's Ok if I use this version in 32 bit... unless I miss something?