Export failing after update to 11.5

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
Maaax
Posts: 7
Joined: 10 Oct 2017, 23:25

Export failing after update to 11.5

Post by Maaax » 16 Feb 2021, 19:36

Hi there,

I've recently upgraded from 11.0.9 to 11.5, I'm on Windows 10.

Before the update I had no problems with exporting, everything worked perfectly, but now after the update I cannot export anything.

Image sequences fail as soon as I click the export button and sequence either fail as soon as I click export, or progresses to 49% and then fails.

I've reinstalled the program multitple times, and tried as best I could to remove any files left over from previous versions, but I can't figure out what is going wrong.

The exact same version and project files works perfectly on my other computer, but I can't figure out what is going wrong with this one.

I can't find anyone with a similar problem online, but I feel like it may be something really simple that I am missing.

Otherwise the program works perfectly.

Could anyone help me out here?

Max

Maaax
Posts: 7
Joined: 10 Oct 2017, 23:25

Re: Export failing after update to 11.5

Post by Maaax » 16 Feb 2021, 20:54

I reinstalled the 11.0.9 version and I am able to export normally again, but ideally I would like to have all my computers running the same version without error.

For 11.5, it doesn't seem to be project specific, I made a quick little sequence and had all the same exporting issues.

User avatar
Xavier
Site Admin
Posts: 759
Joined: 01 Oct 2019, 11:08

Re: Export failing after update to 11.5

Post by Xavier » 16 Feb 2021, 21:25

Wow super strange :shock:
but still :arrow: viewtopic.php?f=10&t=6167
Short but strong

Maaax
Posts: 7
Joined: 10 Oct 2017, 23:25

Re: Export failing after update to 11.5

Post by Maaax » 16 Feb 2021, 22:13

Ooops, forgot my specifics.

Windows 10 64 bit

ryzen 1700 16gb ram

TvPaint 11.5 Pro 64 bit

XP-pen artist 22 E

Thanks.

User avatar
Xavier
Site Admin
Posts: 759
Joined: 01 Oct 2019, 11:08

Re: Export failing after update to 11.5

Post by Xavier » 17 Feb 2021, 10:27

Do you have the two versions installed together ? If so, please try again after uninstalling TVPaint 11.0.9.

And which export format do you use ?
Short but strong

Maaax
Posts: 7
Joined: 10 Oct 2017, 23:25

Re: Export failing after update to 11.5

Post by Maaax » 19 Feb 2021, 15:33

Hi Xavier,

Sorry for the slow response.
When I first updated, I thought it would update the version I had installed rather than installing two versions at the same time.
I have uninstalled both, and just reinstalled the 11.5 version and I still have the same error.
The error is for all export types, every kind of export fails either immediately, or once it reaches 49%.

I feel like maybe the program is not able to access the codecs because it is still attributed to the older version 11.0.9, even though it is not longer installed.

Is there some kind of registry or cache that I can delete to manually reset it?
I don't know, I'm just guessing here. I'm usually pretty computer savvy, but this problem is escaping me.

Thanks.

User avatar
Xavier
Site Admin
Posts: 759
Joined: 01 Oct 2019, 11:08

Re: Export failing after update to 11.5

Post by Xavier » 20 Feb 2021, 13:47

Sure, hit WIN+R and type %APPDATA% to open your Windows user directory.

Then remove the tvp* subfolders.

The codecs are embedded into TVPaint libs, so I see no reason why.
Could it be any of your antivirus / security settings ?
Short but strong

Maaax
Posts: 7
Joined: 10 Oct 2017, 23:25

Re: Export failing after update to 11.5

Post by Maaax » 20 Feb 2021, 19:02

Hi Xavier, and all,

I've found and fixed my problem.
There was nothing wrong with TvPaint at all, it was my Avast antivirus.
Usually when installing a new software it would prompt for an exception to be made, but for some reason, it couldn't tell the difference between 11 and 11.5 so no prompt would appear.
I manually added it to the list of allowed apps, and now everything works fine.
Thanks for your help,

Max

User avatar
Dean
Site Admin
Posts: 396
Joined: 28 May 2018, 09:07

Re: Export failing after update to 11.5

Post by Dean » 22 Feb 2021, 10:07

Hi Maaax, it is strange because for 11.5 we improved the software signature process for TVPaint :lol: now that you mention it, I had already seen some similar issues with antivirus programs, but very niche ones, not the big names such as Avast etc, does yours have special settings or did you keep everything set to default?
-Sales and Support-
Probably a vampire

Maaax
Posts: 7
Joined: 10 Oct 2017, 23:25

Re: Export failing after update to 11.5

Post by Maaax » 23 Feb 2021, 02:37

Hi Dean,

I've kept my Avast with the default settings as far as I can remember. Perhaps it had something to do with having but 11 and 11.5 installed at the same time, as when I first updated I assumed it would override the old version rather than installing an additional version?

Cheers,

Max

User avatar
Xavier
Site Admin
Posts: 759
Joined: 01 Oct 2019, 11:08

Re: Export failing after update to 11.5

Post by Xavier » 23 Feb 2021, 18:51

Yup, Tvpaint executables are signed in theory and your A/v actually lets it start.

The Wibu security may trigger some security rules of your antivirus, but once again Avast lets Tvpaint start & work properly right ?

So maybe it's due to the writing of the file. Do you export into a folder where you have permission to write ? Any security rule related to processes writing files ?
Short but strong

Maaax
Posts: 7
Joined: 10 Oct 2017, 23:25

Re: Export failing after update to 11.5

Post by Maaax » 23 Feb 2021, 19:35

Hi,

Yes, all functionality of the program was there. I could draw, create new brushes, extend exposures, open files and save new ones. It was only when I exported that I had the problem.
I was exporting directly to my desktop, so no weird permissions on the export folder either. And like I said, the video files would export up to 49% and then fail. (I'm assuming this is when the file actually begins to write itself outside the program) Image sequences would fail seemingly immediately, although I never tried with a file heavy enough that a single frame would not be able to be rendered instantly.

I'm not really techy enough understand everything with the problem, but to me it seemed like Avast recognised the 11.5 as the same as 11 when the program opened, so it didn't prompt for new rules, but when it came to exporting the file it viewed it as an unknown program trying to create files and blocked it causing the export to fail.

User avatar
Xavier
Site Admin
Posts: 759
Joined: 01 Oct 2019, 11:08

Re: Export failing after update to 11.5

Post by Xavier » 23 Feb 2021, 21:35

Just try this : remove your network cable or disable WiFi to avoid getting any virus, then uninstall Avast and try again exporting.
To check if Avast is the cause.
Short but strong

Post Reply