[macOS] Update on TVPaint 11.0.9 lag issue

Please use this part to report bugs & errors, ask questions & "How to..."
gjeaks
Posts: 7
Joined: 15 Oct 2016, 14:45

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by gjeaks » 25 Jul 2020, 04:47

Hi, I opened TVP after a few months now (because of the lag issue encountered with the update of Catalina). A lot of issues which I encountered earlier were solved. Except for the brush lag. Right clicking the mouse seemingly recovers the brush for a bit before it goes back to lagging again. Any new brush selected introduces the lag again.

I temp moved to CSP because of this issue, but TVPaint is TVPaint ^_^

Does downgrading TVP help?
MacBook Pro 2019 / macOS Catalina ver.10.15.6 / Core i7 / 16 GB / Intel UHD Graphics 630 1536 MB / Cintiq Pro 16 (driver ver 6.3.38-3) / TVP PRO 11.0.10 64-bit

User avatar
Dean
Site Admin
Posts: 257
Joined: 28 May 2018, 09:07

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by Dean » 27 Jul 2020, 08:47

Hello Gjeaks,
Are you using 11.0.9 or 11.0.10?
-Sales and Support-
Probably a vampire

gjeaks
Posts: 7
Joined: 15 Oct 2016, 14:45

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by gjeaks » 02 Aug 2020, 06:01

Hi Dean, sorry for the delay.

I am using 11.0.10.
MacBook Pro 2019 / macOS Catalina ver.10.15.6 / Core i7 / 16 GB / Intel UHD Graphics 630 1536 MB / Cintiq Pro 16 (driver ver 6.3.38-3) / TVP PRO 11.0.10 64-bit

User avatar
schwarzgrau
Posts: 1077
Joined: 23 Jan 2012, 22:08
Location: Offenbach / Germany
Contact:

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by schwarzgrau » 05 Aug 2020, 11:42

There isn't an update for years, than 10.0.9 comes up, which biggest improvement is that the Standard version now works in 64 bits too, but introduces a really annoying lag. You fix this lag but introduce another one with 10.10. Than nothing happens for months. I have to say at the moment I really don't even consider TVPaint for my next project, since It feels like a slowly dying software (sorry if I'm a bit overdramatic here). It's still the best 2D animation software for me at the moment, but I already try out all possible alternatives, since I don't see any progress.
Mac OS X 10.13.6 / TVP 11.0.8 PRO / Cintiq 22HD
Mac OS X 10.13.6 / TVP 11.0.8 PRO / Cintiq Companion 2
SCHWARZGRAU.COM

User avatar
Thierry
Site Admin
Posts: 2251
Joined: 07 Jan 2013, 08:28

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by Thierry » 07 Aug 2020, 11:28

Hi schwarzgrau,

I understand the frustration about the lag, but as we've said before, the lag is random, not everybody has it, and we cannot reproduce it consistantly.
Some people have it with 11.0.9 and not with 11.0.10, others have it with 11.0.10 and not with 11.0.9, and some also don't have it at all (wether it's 11.0.9 & 11.0.10).
The only common point that we've found with all those that have the lag is that they're using Cintiqs.

We don't have a definitive solution about it, only small solutions. Some of the small solutions don't work on all people while they might work for others.

As for the updates, while it's true that there had been a very long delay between 11.0.8 and 11.0.9 (due to some people leaving the company and us hiring new people), since September 2019 we've released two updates (one of them during confinement), and version 11.5 will release during Fall.
We're also working on a major new version, but that takes time. We are still supporting v11 and we don't plan on ending its support anytime soon.
------------------------------
Si votre question a trouvé réponse, marquez votre sujet comme Résolu. ~ If your question has been answered, mark your topic as Solved.

User avatar
schwarzgrau
Posts: 1077
Joined: 23 Jan 2012, 22:08
Location: Offenbach / Germany
Contact:

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by schwarzgrau » 07 Aug 2020, 11:48

Hi Thierry,
Thank you for your reply. The weird thing is that there is already a pretty consistent bug with Cintiqs, if you switch from another app back to TVPaint, where you can only draw if you use the back of the pen first (you probably already aware of). Seems like there is some major incompatibility with Cintiqs. I'm really sorry you can't reproduce one of these errors, since probably most animators use them.

I'm aware that some people left the company and I'm sure that affects a small company like TVPaint a lot, even if it was some years ago. The features added/bugs fixed in the last two updates seem at least to me pretty minor compared to everything which was added from 10.6 to 10.7 or 10.7 to 10.8, especially if you consider how long there wasn't an update. However that you working on 11.5 and maybe 12 explains it perfectly for me. That's something I was hoping for and I'm really happy to hear.
Thank you Thierry
Mac OS X 10.13.6 / TVP 11.0.8 PRO / Cintiq 22HD
Mac OS X 10.13.6 / TVP 11.0.8 PRO / Cintiq Companion 2
SCHWARZGRAU.COM

User avatar
Xavier
Site Admin
Posts: 211
Joined: 01 Oct 2019, 11:08

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by Xavier » 10 Aug 2020, 13:07

The lag is an issue, that's for sure. The creator of TVPaint didn't expect his baby to be used in such big screen resolutions !
Because yes, the lag is caused by these huge resolutions. The higher is your screen resolution, the more computations TVPaint has to inflict to your processor.

So there's a traffic jam somewhere. But since the traffic is already full, it's not that easy to optimize.
awakened cow

User avatar
schwarzgrau
Posts: 1077
Joined: 23 Jan 2012, 22:08
Location: Offenbach / Germany
Contact:

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by schwarzgrau » 10 Aug 2020, 13:36

Ok this makes perfect sense. The core isn't the freshest, but the 10.0.8 still works flawlessly for me.
Mac OS X 10.13.6 / TVP 11.0.8 PRO / Cintiq 22HD
Mac OS X 10.13.6 / TVP 11.0.8 PRO / Cintiq Companion 2
SCHWARZGRAU.COM

User avatar
daninski
Posts: 251
Joined: 01 Oct 2015, 12:13
Location: Budapest/Newport
Contact:

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by daninski » 12 Aug 2020, 10:07

I've been animating on @ 4K on my current project with no lag, BUT I'm using 11.0.8 still... So I guess the huge resolution problem appears and disappears between versions?
http://www.daninski.com
Award winning director with an iMac from about 2013 and a cintiq from about 2009, there's some RAM too.

User avatar
Xavier
Site Admin
Posts: 211
Joined: 01 Oct 2019, 11:08

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by Xavier » 12 Aug 2020, 11:04

daninski wrote:
12 Aug 2020, 10:07
I've been animating on @ 4K on my current project with no lag, BUT I'm using 11.0.8 still... So I guess the huge resolution problem appears and disappears between versions?
Daninski, If I refer to your signature, your iMac resolution is 1 920 x 1 080 right ?
At this resolution you could even do 8K animation, it should be okay ^^

The issue is related with the amount of hardware pixels to manage, not the amount of pixels in your project.
awakened cow

User avatar
daninski
Posts: 251
Joined: 01 Oct 2015, 12:13
Location: Budapest/Newport
Contact:

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by daninski » 12 Aug 2020, 14:32

That's true, but I got terrible playback lag in 11.0.9 that made review of my animation impossible. I haven't tried the newer versions yet because I'm still mid-project. I will give them a go when everything is delivered. BTW, I'm saying this not as a critique of TVP or their people. I'm offering up my experience of the problem as more information is more useful. Me and TVPaint are BFF.
http://www.daninski.com
Award winning director with an iMac from about 2013 and a cintiq from about 2009, there's some RAM too.

User avatar
Xavier
Site Admin
Posts: 211
Joined: 01 Oct 2019, 11:08

Re: [macOS] Update on TVPaint 11.0.9 lag issue

Post by Xavier » 12 Aug 2020, 15:07

Sure, no worries :wink:

Still we're developers, not animation specialists (or just a little), so we're always interested in having some feedbacks from you guys.
The most difficult thing is to predict all situations, all configurations.
awakened cow

Post Reply