Moving selected instances in multiple layers

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
Posts: 3
Joined: 27 Nov 2019, 18:21

Moving selected instances in multiple layers

Post by pine_needle » 13 Jan 2020, 17:19

Howdy. My issue is pretty simple but I haven't really found a satisfactory answer thru some quick searches on the forum.

I've animated something on several layers. Now I need to move certain sections of the complete animation. So I would've liked to select, say, 10 instances on four different layers and move them forward all together.

I tried CTRL-selecting the relevant layers, then selecting the 10 relevant instances on one of these layers, but then all the other layers get unselected. Also tried selecting the 10 instances first on one of the layers, then tried to select more of the layers but this has the same effect.

Only method I've got right now is more time consuming than I feel it should be: I mark the 10 instances on all layers with a colour to make them stand out, then I move them layer by layer, making sure these coloured segments line up. It's tolerable for the 4 layers I'm working with, but I've animated elements on 10 layers or more and that's more of a problem.

Is this just something I can't do in TVPaint?

Thanks xo

User avatar
Posts: 2468
Joined: 08 May 2008, 21:10
Location: berlin, germany

Re: Moving selected instances in multiple layers

Post by slowtiger » 14 Jan 2020, 11:03

1. Select all affected layers
2. Grab that little handle at the first frame and drag
All frames in all selected layers should move the same amount once you release that handle.
This only works as long as the frame structure of all layers is the same. You can have 12 frames on ones in one layer and a 12 frame hold in another, and grab the first frame and it will work. You cannot have 12 frames on 1's and 12 frames on 2's in another layer and grb the second frame: the point where you grab must have a frame in all layers.
TVP 10.0.18, Mac Pro Quadcore 3 GHz, 16 GB RAM, OS 10.11, QT 7.7.3

Post Reply