Tool Preview

This topic is dedicated to Open Beta versions. Post here your comment, bugs notifications and ideas about the Android version !
Locked
User avatar
Satrip
Posts: 109
Joined: 03 Aug 2007, 15:52
Location: France-85
Contact:

Tool Preview

Post by Satrip » 03 May 2010, 15:02

I've noticed the tool preview under the cursor stay "stuck" near the end of any stroke for barely half a second, before to go back under the cursor..
This is light but a bit annoying.
I know I can set the tool preview off, but there's some drawing tool that are much more convenient to use with it activated.

Also, a few things off-topic:
-Could it be possible to set a custom temp folder?

-I'd like to have the same cursors as in the windows version.. Those opaque cross/arrow/point here are very unconfortable to draw with!

-When launching TVPaint from command line, I always have these lines on the terminal:
"EVENT RESULT : 21
EVENT RESULT : 19"
I don't know if it's important, If it means something to you..

User avatar
Hervé
Site Admin
Posts: 3490
Joined: 08 Feb 2006, 17:00
Location: Metz France
Contact:

Re: Tool Preview

Post by Hervé » 03 May 2010, 15:15

Satrip wrote: I've noticed the tool preview under the cursor stay "stuck" near the end of any stroke for barely half a second, before to go back under the cursor..
Check if the realtime drawing smoothing mode is checked, if not, at the end of the stroke, TVP clear the stroke and redraw it with the good smoothing. This redraw can delay the preview a little bit.
Satrip wrote: Also, a few things off-topic:
-Could it be possible to set a custom temp folder?
in the preference panel: Edit->Preference->General->Temp Directory
Satrip wrote: -When launching TVPaint from command line, I always have these lines on the terminal:
"EVENT RESULT : 21
EVENT RESULT : 19"
I don't know if it's important, If it means something to you..
In a beta version, it's normal to print some info :wink:
Hervé ADAM, TVPaint Team

User avatar
Satrip
Posts: 109
Joined: 03 Aug 2007, 15:52
Location: France-85
Contact:

Re: Tool Preview

Post by Satrip » 03 May 2010, 18:07

I've done a screencast to show precisely my problem.
This happens with or without drawing smooth activated .
I've tried on TVP standard 8.6.4 on winXP, with the exact same tool, it doesn't happen.



Also for the temp directory, I know the option in "Preference" but I can't use it: I can't erase/write anything in it, and when I click on "Choose" nothing happens (with both system and tvp file explorer).
So I guess this is a bug.
Attachments
TvpToolPreview.ogv.zip
(369.08 KiB) Downloaded 376 times

User avatar
Satrip
Posts: 109
Joined: 03 Aug 2007, 15:52
Location: France-85
Contact:

Re: Tool Preview

Post by Satrip » 04 May 2010, 17:52

After more tests I've noticed this tool preview delay appears when I have the Navigator panel open.
As soon as I hide it, the delay disappear.

Also when I activate the "play" button on the Navigator the delay almost disappear (this is strange because it should take more resource to display the animation preview than only a single image preview).

Locked