Import Sound while importing video

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
User avatar
NathanOtano
Posts: 847
Joined: 01 Apr 2014, 07:07
Location: Paris, France
Contact:

Import Sound while importing video

Post by NathanOtano » 29 May 2017, 16:59

Hey, when importing a video in tvpaint I check import sound but it doesn't work. Could it be ffmpeg compatible? I often need to import the animatic with sound on my animation shots to be sure to animate on the right timing.

Nathan
Storyboard, animation and design work : http://nathanotano.tumblr.com/
As I'm highly interested in animation workflows, I'm open to scripting new TVP functions for individuals and studios. Please don't hesitate to contact me!

User avatar
Elodie
Site Admin
Posts: 13068
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Import Sound while importing video

Post by Elodie » 30 May 2017, 04:00

Could you send us the video file ?
Questions or problems regarding the forum ? Please contact me by PM
Question regarding TVPaint or need a quotation ? Please contact me by email

User avatar
NathanOtano
Posts: 847
Joined: 01 Apr 2014, 07:07
Location: Paris, France
Contact:

Re: Import Sound while importing video

Post by NathanOtano » 31 May 2017, 06:47

Okay! :)
Storyboard, animation and design work : http://nathanotano.tumblr.com/
As I'm highly interested in animation workflows, I'm open to scripting new TVP functions for individuals and studios. Please don't hesitate to contact me!

User avatar
Elodie
Site Admin
Posts: 13068
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Import Sound while importing video

Post by Elodie » 12 Jul 2017, 13:27

No problem on my side on Mac.
Questions or problems regarding the forum ? Please contact me by PM
Question regarding TVPaint or need a quotation ? Please contact me by email

User avatar
Greenlaw
Posts: 21
Joined: 10 May 2008, 20:36
Location: Los Angeles, CA, USA
Contact:

Re: Import Sound while importing video

Post by Greenlaw » 22 Sep 2017, 17:42

Hi,

I'm helping my 10-year-old daughter with a school animation project, and we ran into an issue when importing her animatic reference videos. TVPaint is converting the video images as frames as expected but the audio does not import along with the video footage. I double-checked my import settings and the audio import option was definitely enabled.

When I get back to helping her this evening, I'm thinking we'll just extract the audio track for each scene as uncompressed .wav files and import those separately. I'm pretty sure that will work but I'm still wondering why directly importing the video footage didn't work for us.

My guess is that it has to do with the codec we're using. The scene clips were exported from Magix Vegas Pro using the Sony AVC codec, which is an h.264 variant. The container is .mp4.

For this purpose, what's the preferred import video format for TVPaint? (BTW, we're both using TVPaint 11 with Windows 10.) When I have the proper specs, I'd like give that a try before extracting the audio.

Thanks in advance for any helpful info.
D.R. Greenlaw
Artist/Partner, Little Green Dog

User avatar
Greenlaw
Posts: 21
Joined: 10 May 2008, 20:36
Location: Los Angeles, CA, USA
Contact:

Re: Import Sound while importing video

Post by Greenlaw » 22 Sep 2017, 20:46

Hiya,

Just a quick followup:

During my lunch break, I tried again on my tablet computer and the audio imported with the video just fine. Now I'm thinking the issue must be something specific to my daughter's laptop computer. I'll see if I can figure that out tonight.

Anyway, I don't think TVPaint or my video format is at fault here so...never mind. :)
D.R. Greenlaw
Artist/Partner, Little Green Dog

User avatar
slowtiger
Posts: 2052
Joined: 08 May 2008, 21:10
Location: berlin, germany
Contact:

Re: Import Sound while importing video

Post by slowtiger » 22 Sep 2017, 21:29

As a workaround you should be able to export audio only from vegas, and import this to the clip in TVP.
TVP 10.0.18, Mac Pro Quadcore 3 GHz, 16 GB RAM, OS 10.11, QT 7.7.3

User avatar
Greenlaw
Posts: 21
Joined: 10 May 2008, 20:36
Location: Los Angeles, CA, USA
Contact:

Re: Import Sound while importing video

Post by Greenlaw » 22 Sep 2017, 21:39

Thanks for the tip! I'll try that if my daughter's computer won't import the file properly tonight.

Now, I'm hoping it was just a random glitch on her system and maybe it will be okay after a reboot.
D.R. Greenlaw
Artist/Partner, Little Green Dog

User avatar
Greenlaw
Posts: 21
Joined: 10 May 2008, 20:36
Location: Los Angeles, CA, USA
Contact:

Re: Import Sound while importing video

Post by Greenlaw » 23 Sep 2017, 17:05

Ok, we tried it again when I got home last night and this time it worked fine with her computer. She probably had other tasks running in the background at the time, and I'm guessing a reboot fixed it.

Soooo...all is good again.

Thanks for the reply, SlowTiger. :)
D.R. Greenlaw
Artist/Partner, Little Green Dog

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 13 guests