Pen cursor problem (changing to an arrow)

Please use this part to report bugs & errors, ask questions & "How to..."
User avatar
David_Fine
Posts: 529
Joined: 29 Aug 2014, 16:39

Re: Pen cursor problem in 11.03

Post by David_Fine » 23 May 2016, 18:05

Happened again. Have to restart my whole computer to clear it up. Seems to be about once a week. I am posting here to give a sense of the frequency. It is really interruptive and as I say, for me, only since this latest .03 version.
David Fine
iMac late 2014 3.5 GHz, 32GB RAM
Snowden Fine Animation Inc.
Vancouver, Canada

User avatar
furushil
Posts: 404
Joined: 12 Feb 2012, 21:02
Location: Berlin
Contact:

Re: Pen cursor problem in 11.03

Post by furushil » 23 May 2016, 18:20

2dbert wrote:This may not help at all, because my setup is still as listed in my signature, but I remember realizing some time ago what seemed to cause the cursor to turn from point to arrow (in TVP 10).
I believe I had youtube running on auto play in the background whilst working in typ, some old radio show just for some background noise, and whenever auto play put on the next episode in youtube, the cursor would turn into an arrow in tvp. I thought it was strange that the one thing would influence the other, but then I don't know an awful lot about these things and that's what seemed to be the case, or else it must have been a quite persistently ongoing coincidence.
So if this isn't completely out of the question, and if you had some player or iTunes or something of the sort running whilst working at the time the cursor payed up, you could try to reproduce that bug in such a way.
David, what about 2dbert said here? Is iTunes or youtube running in the background while you are working?
If it happens again, could you try to quit all programs except TVPaint and see if the cursor changes back?
MAC OS 10.11.6 - TVpaint 11.0.8 PRO 64bit, Wacom Intuos Pro

User avatar
David_Fine
Posts: 529
Joined: 29 Aug 2014, 16:39

Re: Pen cursor problem in 11.03

Post by David_Fine » 24 May 2016, 22:50

I seem to have overlooked that suggestion, but I will indeed try and report back. Thanks!
David Fine
iMac late 2014 3.5 GHz, 32GB RAM
Snowden Fine Animation Inc.
Vancouver, Canada

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 25 May 2016, 04:18

furushil wrote:
2dbert wrote:This may not help at all, because my setup is still as listed in my signature, but I remember realizing some time ago what seemed to cause the cursor to turn from point to arrow (in TVP 10).
I believe I had youtube running on auto play in the background whilst working in typ, some old radio show just for some background noise, and whenever auto play put on the next episode in youtube, the cursor would turn into an arrow in tvp. I thought it was strange that the one thing would influence the other, but then I don't know an awful lot about these things and that's what seemed to be the case, or else it must have been a quite persistently ongoing coincidence.
So if this isn't completely out of the question, and if you had some player or iTunes or something of the sort running whilst working at the time the cursor payed up, you could try to reproduce that bug in such a way.
David, what about 2dbert said here? Is iTunes or youtube running in the background while you are working?
If it happens again, could you try to quit all programs except TVPaint and see if the cursor changes back?
Thank you for quoting 2dbert message, I has missed it. I think this can be a part of the problem because I had some cursors mistakes when I was listening to youtube o itunes. But it lasts a few seconds before switching to the normal cursor. So, still have no clue.

I will test it anyway on other computers and see whether we can definitely trigger this bug, just like David experiences it.

User avatar
David_Fine
Posts: 529
Joined: 29 Aug 2014, 16:39

Re: Pen cursor problem in 11.03

Post by David_Fine » 30 May 2016, 05:27

This may be a related issue I just discovered. I always set my eraser to be a red pen, set on erase. That way, when I use it with the rocker button on the pen, it changes to a red blob, which is a nice visual to tell me that I am using the eraser and also the size of it. (That was a tip from Paul F.) I just noticed that the erase no longer shows the red colour circle, just the point (I have it set to point). Now I can't tell the size of the eraser, which makes careful erasing more difficult. How did this change?

I then went to preferences to try changing from the point to circle to see if that would help, but instead of getting a circle, I get the arrow pointer. The same arrow pointer I get which I have been writing about earlier and which I have to restart the computer to go back to the point. In this case though, when I go back to prefs and change from circle to point, the arrow does change back to the point.

So lots of strange behaviour for me with the pen cursor. Not being able to tell the size of the eraser I am using is really a drag and I'm not sure why it worked before, but not now.
David Fine
iMac late 2014 3.5 GHz, 32GB RAM
Snowden Fine Animation Inc.
Vancouver, Canada

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 11 Jul 2016, 04:51

I will answer a part of the question posted here : http://forum.tvpaint.com/viewtopic.php? ... 034#p94077" onclick="window.open(this.href);return false;

So no, this cursor issue is not fixed yet for the reasons I've already given (cannot reproduce it).

When the arrow is back, what if you change the cursor in tvpaint preferences ?

User avatar
furushil
Posts: 404
Joined: 12 Feb 2012, 21:02
Location: Berlin
Contact:

Re: Pen cursor problem in 11.03

Post by furushil » 13 Jul 2016, 11:17

I just had this issue again but when I quit safari and photoshop the issue was resolved and the cursor was back to normal.

David, I recommend you to quit all applications except for TVPaint and see if the cursor changes back.
MAC OS 10.11.6 - TVpaint 11.0.8 PRO 64bit, Wacom Intuos Pro

User avatar
David_Fine
Posts: 529
Joined: 29 Aug 2014, 16:39

Re: Pen cursor problem in 11.03

Post by David_Fine » 21 Jul 2016, 00:59

The problem has not happened for a while and it just did, so I started by quitting Photoshop and... It fixed it!! So that's really interesting. Good to know there is this fix, but I wonder what causes it because it's only happening within TVPaint. Thanks for the tip about Photoshop. I did not need to quite Safari to fix it.
David Fine
iMac late 2014 3.5 GHz, 32GB RAM
Snowden Fine Animation Inc.
Vancouver, Canada

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 21 Jul 2016, 04:18

I will ask our admin to rent Photoshop for a month and see if we can fix that.

Great tip indeed ! I don't know if it will be the solution to fix it, but at least it's a good step forward ! :)

User avatar
Fabrice
Posts: 10079
Joined: 17 Jul 2007, 15:00
Contact:

Re: Pen cursor problem in 11.03

Post by Fabrice » 03 Aug 2016, 07:21

ok, so now we can investigate deeper !
Fabrice Debarge

User avatar
schwarzgrau
Posts: 1062
Joined: 23 Jan 2012, 22:08
Location: Offenbach / Germany
Contact:

Re: Pen cursor problem in 11.03

Post by schwarzgrau » 29 Oct 2016, 13:37

I don't know if this helps in any way: I started rendering something in After Effects CS6 and the cursor became this kind of loading curser, where it fills with white and then with black....some kind of loading cursor. I hided After Effects to draw in TVPaint and noticed that the cursor is still this loading cursor, which was pretty annoying. I switched back to After Effects, than again to TVPaint and I got my old cross back.
This seemed to me like After Effects would control the appearance of the cursor in some way.
Mac OS X 10.11.6 / TVP 11.0.8 PRO / Cintiq 22HD
Mac OS X 10.11.6 / TVP 11.0.8 PRO / Cintiq Companion 2
SCHWARZGRAU.COM

User avatar
D.T. Nethery
Posts: 2531
Joined: 27 Sep 2006, 19:19

Re: Pen cursor problem in 11.03

Post by D.T. Nethery » 19 Dec 2016, 13:35

Monday , December 19 , 2016 -

For the record , this issue of the pen cursor randomly changing from Cross to Arrow was just reported to me by one of the other artists working on the project that I'm working on. He wondered if I had encountered the issue and how to fix it .

Here is the odd thing: nothing has changed on his Mac that he knows of ; he didn't recently update the OS or install any new software , but all of a sudden after months of using TVPaint , he now has this annoying issue of the pen cursor changing from Cross to Arrow .

I forwarded him the tip to turn off Photoshop and other apps , and to not have YouTube or iTunes running in the background while using TVPaint to see if that fixes the pen cursor issue . Maybe that will help him, but that seems like a very annoying workaround ... why should anyone have to not listen to iTunes or YouTube while they are working ? Many people listen to music or podcasts while spending long hours working at the Cintiq , so to be told: "try working without iTunes or YouTube running in the background" is more than a little bit disappointing as a "fix".
MAC OS 10.12.6 , Macbook Pro Retina 15-inch, Mid 2015,
2.5 GHz Intel Core i7, 16 GB Memory , TVPaint PRO 11.0.8, 64bit -
Wacom Cintiq 21 UX - Wacom Intuos Pro 5 - driver version 6.3.20-8

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 19 Dec 2016, 15:53

The problem seems to come from notification : when I use itunes and music switches, I get the arrow and I just have to click on an icon to get the cross cursor back. I don't have any trouble with Youtube.

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 07 Feb 2017, 07:34

Just to keep you posted :

Someone just told me having the same issue on Mac 10.10.5 (Yosemite). He is not listening to Youtube or iTunes : only Photoshop, Chrome and Firefox are running in addition of TVPaint.
Seems like there is sort of a conflict between Adobe and TVPaint, we will have a look on it.

User avatar
daninski
Posts: 223
Joined: 01 Oct 2015, 12:13
Location: Budapest/Newport
Contact:

Re: Pen cursor problem in 11.03

Post by daninski » 07 Feb 2017, 12:04

Elodie wrote:The problem seems to come from notification : when I use itunes and music switches, I get the arrow and I just have to click on an icon to get the cross cursor back. I don't have any trouble with Youtube.

You don't even need to click on the icon, if you just move the arrow over your controls or brushes it turns back into the crosshair.
http://www.daninski.com
Award winning director with an iMac from about 2013 and a cintiq from about 2009, there's some RAM too.

Post Reply