Pen cursor problem (changing to an arrow)

Please use this part to report bugs & errors, ask questions & "How to..."
2dbert
Posts: 61
Joined: 08 Aug 2008, 20:49

Re: Pen cursor problem in 11.03

Post by 2dbert » 12 Apr 2016, 19:33

This may not help at all, because my setup is still as listed in my signature, but I remember realizing some time ago what seemed to cause the cursor to turn from point to arrow (in TVP 10).
I believe I had youtube running on auto play in the background whilst working in typ, some old radio show just for some background noise, and whenever auto play put on the next episode in youtube, the cursor would turn into an arrow in tvp. I thought it was strange that the one thing would influence the other, but then I don't know an awful lot about these things and that's what seemed to be the case, or else it must have been a quite persistently ongoing coincidence.
So if this isn't completely out of the question, and if you had some player or iTunes or something of the sort running whilst working at the time the cursor payed up, you could try to reproduce that bug in such a way.
Mac OSX Version 10.9 - 2GHz Intel Core 64(? I think so at least)bit - 4GB 1600 MHz DDR3 - Intel HD Graphics 4000 1024 MB
Yiynova MSP19U
TvPaint Animation 11.0.6 Pro

User avatar
Fabrice
Posts: 10079
Joined: 17 Jul 2007, 15:00
Contact:

Re: Pen cursor problem in 11.03

Post by Fabrice » 12 Apr 2016, 19:48

Hmm, I think we fixed this one, but will try anyway.
Fabrice Debarge

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 13 Apr 2016, 06:05

Yes, that is the bug fixed in TVPAINT 11.0.3, and that's why we're trying to figure out how David can still experience it. :)

But thanks for your concern, that's nice !

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 20 Apr 2016, 04:52

(I took the liberty to answer your question from that topic, on this one instead -just to keep things clear and we'll organised-)
Elodie, can you help with this pointer thing? Last time it took about 5 days between it happening, now it has happened twice in two days and I have to restart my entire computer to fix it, which is a pain. This has only started happening since version 10.0.3 and the notes indicate that something was changed about the pointer issue. Previously it happened, but just clicking outside the drawing area would reset it, so no need to restart.
Sadly, I am unable to reproduce your issue, and developers can't either.

A little question : when you installed the last version, d you close tvpaint before ? If your're not sure, could you reinstall it (with tvpaint closed obviously).

Plus, why do you need to restart the Mac ? Won't it be enough enough simply close tvpaint and restart the software only ?

User avatar
furushil
Posts: 404
Joined: 12 Feb 2012, 21:02
Location: Berlin
Contact:

Re: Pen cursor problem in 11.03

Post by furushil » 20 Apr 2016, 20:17

I also experienced the problem that David is describing but fortunately it happens very very rarely -maybe once in two months. The last time was a couple of minutes ago, though. I have no idea what is causing it.
Elodie wrote:Plus, why do you need to restart the Mac ? Won't it be enough enough simply close tvpaint and restart the software only ?
Unfortunately, restarting TVPaint does not help. It seems that the only way to resolve it is to restart the computer.

I will try to record it if I know how to reproduce it.
MAC OS 10.11.6 - TVpaint 11.0.8 PRO 64bit, Wacom Intuos Pro

User avatar
David_Fine
Posts: 529
Joined: 29 Aug 2014, 16:39

Re: Pen cursor problem in 11.03

Post by David_Fine » 20 Apr 2016, 21:58

Oh, I am relieved to hear that I am not the only one with this problem. Yes indeed, restarting TVPaint alone does not fix it. Like Furishil says, only a complete computer restart fixes the cursor problem and by the way, it's only in TVPaint. No such curser issues in any other program running at the same time. Because it happens intermittently, it's virtually impossible to video it happening. Might take a week or two, or happen twice in one day.
David Fine
iMac late 2014 3.5 GHz, 32GB RAM
Snowden Fine Animation Inc.
Vancouver, Canada

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 21 Apr 2016, 04:39

Good to know, thank you Furushil.

This kind of random bug, as you know, is a real pain in the ass to find.

At least, I see Furushil and I are using the same OS version, so there is still hope :)

User avatar
David_Fine
Posts: 529
Joined: 29 Aug 2014, 16:39

Re: Pen cursor problem in 11.03

Post by David_Fine » 21 Apr 2016, 06:21

It is a pain to find, so I wonder if you can switch whatever was changed in .03 back to how it was before so that at least it is fixable without having to restart the whole computer. Of course, if you can manage to find it and fix it, even better.
David Fine
iMac late 2014 3.5 GHz, 32GB RAM
Snowden Fine Animation Inc.
Vancouver, Canada

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 21 Apr 2016, 07:23

Yes, but before it was much worst, since the bug with hte cursor was more frequent :|

User avatar
furushil
Posts: 404
Joined: 12 Feb 2012, 21:02
Location: Berlin
Contact:

Re: Pen cursor problem in 11.03

Post by furushil » 21 Apr 2016, 07:33

David_Fine wrote:It is a pain to find, so I wonder if you can switch whatever was changed in .03 back to how it was before so that at least it is fixable without having to restart the whole computer. Of course, if you can manage to find it and fix it, even better.
I experienced the issue about two times before the version 11.0.3. I think, switching back would not solve it.
MAC OS 10.11.6 - TVpaint 11.0.8 PRO 64bit, Wacom Intuos Pro

m-ries
Posts: 2
Joined: 26 Feb 2016, 14:01

Re: Pen cursor problem in 11.03

Post by m-ries » 25 Apr 2016, 10:26

I do not have the problem described here initially in TVP 11.3 64 bit / Mac OS 10.11.3 but I would like to add that I have issues with the "Point" and "Circle" - mode of the pen cursor. Those problems have happened both in 11.2 and 11.3 :
The Circle-cursor does not appear to be implemented; instead the default arrow is displayed.
The Point-cursor ist displayed, but the spot it points to is not exactly where the brush stroke appears. So I always would have to point a little bit lower and a bit more to the right from the spot where I want to draw.
Leaving out the Pen 1-4 options, the Cross-cursor currently is the only one useable for me.

Thanks and best regards!
Matthias

User avatar
David_Fine
Posts: 529
Joined: 29 Aug 2014, 16:39

Re: Pen cursor problem in 11.03

Post by David_Fine » 25 Apr 2016, 16:58

furushil wrote:I experienced the issue about two times before the version 11.0.3. I think, switching back would not solve it.
Yeah, so really, the solution is just to fix it fully rather than go back to something else which was an issue in it's own way. My experience was that the previous version had this problem, but at least I didn't have to restart my computer, which is a pain. Hope this gets addressed soonish. Thanks.
David Fine
iMac late 2014 3.5 GHz, 32GB RAM
Snowden Fine Animation Inc.
Vancouver, Canada

User avatar
David_Fine
Posts: 529
Joined: 29 Aug 2014, 16:39

Re: Pen cursor problem in 11.03

Post by David_Fine » 25 Apr 2016, 18:35

Aargh! It just happened again now, mere minutes after my last post. All I did was choose a pen to start drawing with and poof, it changed to an arrow and will not swap back to the point. No crazy or unusual use of TVPaint. Just a mundane use of a pen. Just one scene open. This is typical, in that it happens for no particular reason, so I really hope you might be able to look into this soon. Thanks.
David Fine
iMac late 2014 3.5 GHz, 32GB RAM
Snowden Fine Animation Inc.
Vancouver, Canada

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Pen cursor problem in 11.03

Post by Elodie » 09 May 2016, 05:19

Random bugs are the worst to track and fix...

User avatar
David_Fine
Posts: 529
Joined: 29 Aug 2014, 16:39

Re: Pen cursor problem in 11.03

Post by David_Fine » 16 May 2016, 22:40

Happened again. I have to restart my whole computer to fix it. Any chance this might be addressed any time soon? As I mentioned, for me it never happened in the previous version so maybe just changing whatever was done, back to that would be better as it's so interruptive to have to close everything down and restart.
David Fine
iMac late 2014 3.5 GHz, 32GB RAM
Snowden Fine Animation Inc.
Vancouver, Canada

Post Reply