Quite annoying bug of the jumping timeline in Project mode

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
User avatar
Soom
Posts: 835
Joined: 25 Jul 2011, 16:25
Location: World
Contact:

Quite annoying bug of the jumping timeline in Project mode

Post by Soom » 24 Mar 2021, 19:38

I have posted a similar problem already about moving layers in Timeline - now this bug is manifesting itself also in the Project view.
When I drag clips in the Project window, it is very difficult to control the location where it would drop, because the window scrolls too fast and abrupt. Besides if moving a clip to the right edge, it never drops there, but instead drops at the very end of the timeline. This impacts the sroryboarding process quite a lot and makes it frustrating. Please fix this behavior. thanks
Here is a screen recording of the problem:
Hackintosh, OS 10.13.6, Cintiq 22", TVP Pro 11.5.1, http://danasb.com

User avatar
Thierry
Site Admin
Posts: 2360
Joined: 07 Jan 2013, 08:28

Re: Quite annoying bug of the jumping timeline in Project mode

Post by Thierry » 25 Mar 2021, 11:18

Hi Soom,

I've tried to replicate this on my side, and I confirm that the window scrolls quite fast, although I'm not sure how we can make it slower.
I can also confirm the bug about moving a clip to the right edge, and I think this one can be fixed relatively easily.

I'll add both of these bugs to our list.

---
TVPaint Pro 11.5.1, Windows
Si votre question a trouvé réponse, marquez votre sujet comme Résolu.
If your question has been answered, mark your topic as Solved.

User avatar
Peter Wassink
Posts: 3783
Joined: 17 Feb 2006, 15:38
Location: Amsterdam
Contact:

Re: Quite annoying bug of the jumping timeline in Project mode

Post by Peter Wassink » 25 Mar 2021, 17:54

Isn't it possible to simply slow down the scroll speed as the cursor approaches the edge?

like having a small bufferzone that gradually lowers the scroll speed as you get deeper in it.
Peter Wassink - 2D animator
• PC: Win10/64 Home - Xeon Quadcore E5410@2.33Ghz - 12Gb RAM
• laptop: Win10/64 Pro - i7-4600@2.1 GHz - 16Gb RAM

User avatar
Soom
Posts: 835
Joined: 25 Jul 2011, 16:25
Location: World
Contact:

Re: Quite annoying bug of the jumping timeline in Project mode

Post by Soom » 25 Mar 2021, 20:17

Thierry wrote:
25 Mar 2021, 11:18
Hi Soom,

I've tried to replicate this on my side, and I confirm that the window scrolls quite fast, although I'm not sure how we can make it slower.
I can also confirm the bug about moving a clip to the right edge, and I think this one can be fixed relatively easily.

I'll add both of these bugs to our list.

---
TVPaint Pro 11.5.1, Windows
Thank you Thierry for checking!
Peter Wassink wrote:
25 Mar 2021, 17:54
Isn't it possible to simply slow down the scroll speed as the cursor approaches the edge?

like having a small bufferzone that gradually lowers the scroll speed as you get deeper in it.
Yes - I was thinking the same. There are a lot of apps that don't scroll so fast - sorry to put it here as an example, but Toon boom Harmony is one of them. I am sure it should be something very simple like overriding default scrolling speeds, but of course I don't know coding, so I might be missing something...
Hackintosh, OS 10.13.6, Cintiq 22", TVP Pro 11.5.1, http://danasb.com

User avatar
D.T. Nethery
Posts: 2958
Joined: 27 Sep 2006, 19:19

Re: Quite annoying bug of the jumping timeline in Project mode

Post by D.T. Nethery » 26 Mar 2021, 14:28

I noticed that I do not have this problem ("if moving a clip to the right edge, it never drops there, but instead drops at the very end of the timeline.") I tried to reproduce your problem, but when I drag and drop a clip to the right edge it drops precisely where I let go of it , it does not jump to the end of the timeline. Also, I find that the scrolling is a controllable speed , I don't have any problem to drag and drop a clip where I want it .

➔ However, this made me wonder if the problem is in the System Preferences mouse tracking speed. I checked and I notice that my mouse tracking speed is set to the slow end of the scale. When I changed my mouse tracking speed to the fast end of the scale I can reproduce your problem exactly . With my mouse tracking speed in System Prefs set to fast then the scrolling in TVPaint is too fast to control and any clip placed to the right edge jumps to the end of the timeline .

Mouse Tracking Speed Slower is OK.jpg
Mouse Tracking Speed Fast causes a Problem.jpg

Animator, TVPaint Beta-Tester, Animation Educator and Consultant.
MAC OS 10.14.6 , Macbook Pro Retina 15-inch, Late 2013,
2.3 GHz Intel Core i7, 16 GB Memory , TVPaint PRO 11.5.1 - 64bit ,
Wacom Cintiq 21 UX ,Wacom Intuos Pro 5 , Wacom driver version 6.3.39-1

User avatar
Soom
Posts: 835
Joined: 25 Jul 2011, 16:25
Location: World
Contact:

Re: Quite annoying bug of the jumping timeline in Project mode

Post by Soom » 28 Mar 2021, 00:04

D.T. Nethery wrote:
26 Mar 2021, 14:28
➔ However, this made me wonder if the problem is in the System Preferences mouse tracking speed. I checked and I notice that my mouse tracking speed is set to the slow end of the scale. When I changed my mouse tracking speed to the fast end of the scale I can reproduce your problem exactly . With my mouse tracking speed in System Prefs set to fast then the scrolling in TVPaint is too fast to control and any clip placed to the right edge jumps to the end of the timeline .
Hmm, I have tried to play around with Tracking speed settings both on the mouse and on the trackpad and I couldn't make it work properly. Which OS and TVP version do you use? Mine is High Sierra and TVPaint 11.0.10 - 32bits
Hackintosh, OS 10.13.6, Cintiq 22", TVP Pro 11.5.1, http://danasb.com

User avatar
D.T. Nethery
Posts: 2958
Joined: 27 Sep 2006, 19:19

Re: Quite annoying bug of the jumping timeline in Project mode

Post by D.T. Nethery » 28 Mar 2021, 02:03

Soom wrote:
28 Mar 2021, 00:04
D.T. Nethery wrote:
26 Mar 2021, 14:28
➔ However, this made me wonder if the problem is in the System Preferences mouse tracking speed. I checked and I notice that my mouse tracking speed is set to the slow end of the scale. When I changed my mouse tracking speed to the fast end of the scale I can reproduce your problem exactly . With my mouse tracking speed in System Prefs set to fast then the scrolling in TVPaint is too fast to control and any clip placed to the right edge jumps to the end of the timeline .
Hmm, I have tried to play around with Tracking speed settings both on the mouse and on the trackpad and I couldn't make it work properly. Which OS and TVP version do you use? Mine is High Sierra and TVPaint 11.0.10 - 32bits
Mac OS 10.14 Mojave , TVPaint 11.5.1 64bits.

I have TVPaint 11.0.10 and after testing with 11.0.10 I can confirm that the problem exists on 11.0.10 , if I drag and drop a clip all the way over to the right edge it jumps to the end. But I don't get that problem with 11.5.1 .

Animator, TVPaint Beta-Tester, Animation Educator and Consultant.
MAC OS 10.14.6 , Macbook Pro Retina 15-inch, Late 2013,
2.3 GHz Intel Core i7, 16 GB Memory , TVPaint PRO 11.5.1 - 64bit ,
Wacom Cintiq 21 UX ,Wacom Intuos Pro 5 , Wacom driver version 6.3.39-1

User avatar
Soom
Posts: 835
Joined: 25 Jul 2011, 16:25
Location: World
Contact:

Re: Quite annoying bug of the jumping timeline in Project mode

Post by Soom » 28 Mar 2021, 23:40

Hmm, Ok, I have just updated to 11.5 and the problem still exists. Playing around with tracking speeds didn't change anything... Maybe it's OS specific, not sure, but TVPaint team confirmed that too, so I hope it will be fixed some time soon...
Hackintosh, OS 10.13.6, Cintiq 22", TVP Pro 11.5.1, http://danasb.com

User avatar
D.T. Nethery
Posts: 2958
Joined: 27 Sep 2006, 19:19

Re: Quite annoying bug of the jumping timeline in Project mode

Post by D.T. Nethery » 29 Mar 2021, 15:37

Soom wrote:
28 Mar 2021, 23:40
Hmm, Ok, I have just updated to 11.5 and the problem still exists. Playing around with tracking speeds didn't change anything... Maybe it's OS specific, not sure, but TVPaint team confirmed that too, so I hope it will be fixed some time soon...

Now I have to report back something very odd : using a different project in TVPaint 11.5.1 I now have the problem of a clip that is moved to the far right edge jumping to the end !

Weird that I could not reproduce the issue at all before (unless I changed the mouse tracking speed to Fast) , but now with no other changes to my system, with my mouse tracking speed set at the Slow end of the scale (not slowest , but close) I now get the problem you described. (I still do not notice a problem with the scrolling speed , it seems accurate to me to be able to drag and drop a clip wherever I want to put it with no difficulty , the speed is not too fast ... but if I try to drag and drop a clip to the far right side it jumps to the end. )

I wonder if it has something to do with I opened older version TVPaint 11.0.10 to try to see if I could reproduce the problem in 11.0.10 (yes) , so now that I have gone back to 11.5.1 it somehow changed something so that now 11.5.1 has the same behavior ? Later today I will try it again. First I will move my 11.0.10 version to an external hard drive , then delete it on my main computer ,then after backing up my custom panels I'll do a clean install of 11.5.1 with a fresh configuration to see the problem goes away.

Animator, TVPaint Beta-Tester, Animation Educator and Consultant.
MAC OS 10.14.6 , Macbook Pro Retina 15-inch, Late 2013,
2.3 GHz Intel Core i7, 16 GB Memory , TVPaint PRO 11.5.1 - 64bit ,
Wacom Cintiq 21 UX ,Wacom Intuos Pro 5 , Wacom driver version 6.3.39-1

Post Reply