Custom panel deleted by mistake needs reinstating

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
johnfromncl
Posts: 29
Joined: 29 Jul 2019, 08:46
Location: Whitley Bay, England

Custom panel deleted by mistake needs reinstating

Post by johnfromncl » 23 Mar 2021, 22:39

My version of TVPaint is as in my signature: 11 Pro, 11.5.0-64 bits. It is a mac I'm using.
I have been working on creating my own custom panel of brushes over the past few days.
I have saved it fairly often. I have even done a fairly recent system backup to time machine, though the file I deleted by mistake was more recently saved to my computer than that backup.
I was wanting to delete a brush (I did the grab twice by mistake), I have deleted the panel. There seems to be no quick 'undo' for this action.
I can see something with the same name as my panel ('My Custom EF panel') in my finder (it seems to have no file extension name), with the first bit of the contents looking hopeful - for example 'Luma Invert Bristle' half way down is the name of a brush I created. An image of a sample from the top seen in a text editor follows (a click on the image will show the contents clearly)
Might be my brush panel file.png
Dragging that file into TVPaint does not work - it does not load that panel and its brushes as I would expect it to and I get this message.
Message from TVPaint.png
I'm hesitant to 'randomly' try things that are broadly related from previous comments relating to older versions of TVPaint - I've got a feeling some things relating to panels have changed in this latest version.
My question is: How can I reliably get back to where I was?
Any help is gratefully appreciated.
iMac (Retina 5K, 27-inch, 2020). 3.8 Ghz 8-core Intel Core i7, 128GB 2667 MHz DDR4. MacOS Catalina 10.15.7.
TVPaint Animation 11 Pro (11.5.0-64 bits).
Wacom Cintiq 16 Full HD Display (the 2019 lower-resolution one). Driver 6.3.41-2.
John from Newcastle, johnfromncl

johnfromncl
Posts: 29
Joined: 29 Jul 2019, 08:46
Location: Whitley Bay, England

Re: Custom panel deleted by mistake needs reinstating

Post by johnfromncl » 24 Mar 2021, 00:02

WHAT SEEMS TO BE THE SOLUTION
I have added the extension .tvpx to that file and now it drags over into TVPaint okay.
It would be good if TVPaint can confirm that this is what should have been done.
Thanks
iMac (Retina 5K, 27-inch, 2020). 3.8 Ghz 8-core Intel Core i7, 128GB 2667 MHz DDR4. MacOS Catalina 10.15.7.
TVPaint Animation 11 Pro (11.5.0-64 bits).
Wacom Cintiq 16 Full HD Display (the 2019 lower-resolution one). Driver 6.3.41-2.
John from Newcastle, johnfromncl

Post Reply