Ping Pong function not working

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
BruceM
Posts: 201
Joined: 17 Jan 2014, 15:39

Ping Pong function not working

Post by BruceM » 04 Dec 2018, 00:35

I'm doing a simple ball bouncing. The first drawing with the ball at the highest point, and the last frame with the ball at the lowest point on the ground.
I'm setting the Ping Pong function to make the ball bounce on it's own, but it's not working. It's simply playing straight ahead and then popping back to the first frame and playing straight ahead.

What am I doing wrong?

User avatar
melanie
Site Admin
Posts: 404
Joined: 12 Sep 2017, 07:13

Re: Ping Pong function not working

Post by melanie » 04 Dec 2018, 08:42

If you have only one layer, then the animation playback will only play the frames contained in that layer. Then the post-behviour ping-pong will not be played.
You need to create another layer which ends where you want the animation to stop and start over.
The animation playback will play until the farthest image of your longest layer. Unless you place a Mark Out before then.
Mélanie Do Monte • Sales & Support

User avatar
daninski
Posts: 160
Joined: 01 Oct 2015, 12:13
Location: Budapest/Newport
Contact:

Re: Ping Pong function not working

Post by daninski » 04 Dec 2018, 12:21

The other option is to use the in layer "repeat Images" function rather than the tag at the end of the layer. I find this is really useful for keeping a project tidy too...

https://www.tvpaint.com/doc/tvp11/index ... eat-images
http://www.daninski.com
Award winning director with an iMac from about 2013 and a cintiq from about 2009, there's some RAM too.

BruceM
Posts: 201
Joined: 17 Jan 2014, 15:39

Re: Ping Pong function not working

Post by BruceM » 04 Dec 2018, 17:10

Thanks Melanie and Daninski!

Post Reply