problem with the transparency in the json export/import - BUG report Topic is solved

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
User avatar
skomdra
Posts: 119
Joined: 14 Aug 2010, 14:32

problem with the transparency in the json export/import - BUG report

Post by skomdra » 09 Sep 2018, 18:06

Hello,

The exporter (or importer to After Effects, it is difficult to know for sure) creates image files which are interpreted as nontransparent in After Effects if the image in TVP is the empty frame. I managed to detect images which cause problems and had them interpreted manually as transparent images. This is far from the ideal workflow. It is either with the TVP exporter or the import script. The export and the import script ship with the official build of TVP, I consider this a bug and I would like to be addressed in the development. I was using this settings: TIFF (non-compressed), RGBA, PreMult. the background unticked.

Best regards,
-----
TV Paint 11.0.3-64 bits ; iMac (Retina 5K, 27-inch, Late 2014) ; OSX 10.12.5 (16F73) ; AMD Radeon R9 M295X 4096 MB; Wacom Driver version: 6.3.22-3

User avatar
Clément
Site Admin
Posts: 79
Joined: 25 Jan 2017, 08:38

Re: problem with the transparency in the json export/import - BUG report

Post by Clément » 11 Sep 2018, 11:54

Hi.
Indeed this was a bug, the import-json script lacked some instructions in order to interpret the alpha channel correctly on premultiplied footage.
Thanks.
Clement Berthaud, Software Developer, TVPaint Team

Post Reply