fixing H.264 gamma shift

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
User avatar
D.T. Nethery
Posts: 2305
Joined: 27 Sep 2006, 19:19

fixing H.264 gamma shift

Post by D.T. Nethery » 16 Aug 2018, 15:50

We all know that H.264 compression codec has a problem with gamma shift (making the color look "washed out/lighter") .

There is a plug-in by Takashi Mochizuki called x264Encoder . This plugin is based on the award-winning x264 project, but it has over ten times as many fine controls on its settings page than the other x264 plugin. Most importantly, it corrects the gamma shift problem. Read more about it here: https://myth.li/2010/07/how-to-fix-the- ... quicktime/

I have installed it in my Quicktime plug-ins folder and using Quicktime Pro to export with H.264 codec (using Takashi Mochizuki 's x264 Encoder) it does fix the washed-out gamma problem.

But when I try to export to Quicktime .mov (with TVPaint 32bits version) if I select the compression type as x264 Encoder and set the options to correct the gamma , it immediately causes TVPaint to crash. Can someone from TVPaint test this on your Mac and let me know if you get the same results and if there is any to fix for the problem so that I can export from TVPaint using the x264 Encoder compression codec ?
MAC OS 10.11.6 , Macbook Pro Retina 15-inch, Mid 2015,
2.5 GHz Intel Core i7, 16 GB Memory , TVPaint PRO 11.0.6, 64bit -
Wacom Cintiq 21 UX - Wacom Intuos Pro 5 - driver version 6.3.20-8

Post Reply