Particles:: Animation mode missing

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
User avatar
slowtiger
Posts: 2031
Joined: 08 May 2008, 21:10
Location: berlin, germany
Contact:

Particles:: Animation mode missing

Post by slowtiger » 24 Aug 2017, 18:35

So there I had the idea of creating snow with lots of different flakes. Put 2 dozens of them into an AnimBrush and saved that, then used this as souce in Particle FX. BUT: while in brush mode I have the animation option "random and hold", this isn't present in the FX menu. I tried what was there, but none gave me what I wanted: randomly choose a frame of the brush and hold it for the life of that particle. (I also saved the brush with "random and hold" which doesn't make any difference.)

Any fast solution, or is this going to be a feature request?
TVP 10.0.18, Mac Pro Quadcore 3 GHz, 16 GB RAM, OS 10.11, QT 7.7.3

User avatar
Elodie
Site Admin
Posts: 12876
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Particles:: Animation mode missing

Post by Elodie » 25 Aug 2017, 06:08

There are actually many options missing in particles (it's the only effect that won't let you access classical options like clip, layers, project, etc...), so I am not surprised that animation modes are also missing.
Questions or problems regarding the forum ? Please contact me by PM
Question regarding TVPaint or need a quotation ? Please contact me by email

User avatar
slowtiger
Posts: 2031
Joined: 08 May 2008, 21:10
Location: berlin, germany
Contact:

Re: Particles:: Animation mode missing

Post by slowtiger » 25 Aug 2017, 08:37

So there's no other solution than making each snowflake its own Shape? This sucks ...
TVP 10.0.18, Mac Pro Quadcore 3 GHz, 16 GB RAM, OS 10.11, QT 7.7.3

User avatar
slowtiger
Posts: 2031
Joined: 08 May 2008, 21:10
Location: berlin, germany
Contact:

Re: Particles:: Animation mode missing

Post by slowtiger » 25 Aug 2017, 19:17

OK, I exported every single snowflake separately, then put them into particles via duplicating/renaming particle, click shape, browse ... and this 26times. I really hate to work like this with a computer, this is the sort of job it is supposed to be good at!

I've noticed some more things: the little profile popup needs to be closed by click, it lacks an OK button (and to be closed with return). This is a general UI topic: I think wherever possible, things need to be navigatable/closeable via keyboard, for power users or when you have to repeatedly adjust stuff.

The result is quite nice now:
schnee2.gif
TVP 10.0.18, Mac Pro Quadcore 3 GHz, 16 GB RAM, OS 10.11, QT 7.7.3

o0Ampy0o
Posts: 96
Joined: 25 Oct 2015, 22:26

Re: Particles:: Animation mode missing

Post by o0Ampy0o » 25 Aug 2017, 22:50

That is a very nice stylized 3D effect. Reminds me of those flat geometric designs which reveal 3D form when you slightly relax your focus..........in the way it surprises me how much depth it seems to have.
Main System: Mac Pro running OS X: 10.10.5 | 3.8GHz i7 | 32GB RAM | 64-bit TVPaint Pro 11.0.6 | iPad Pro, Apple Pencil and Astropad | Wacom Intros Pro using Driver: 6.3.21-8

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 18 guests