Search found 1 match

by Sketchtoanimate
25 Jun 2020, 07:02
Forum: Technical Support
Topic: Running Catalina 15.5 and the sentinel driver says it is incompatible
Replies: 1
Views: 392

Running Catalina 15.5 and the sentinel driver says it is incompatible

I need help getting my single to work with my MacBook Pro and macOS Catalina 10.15.5 downloaded the sentinel driver but it say it is incompatible . What can I do to get this software running ?
Cheers!